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Itroduction 

 

1 Introduction 
 

This User Manual will show you how to install the GNU Toolchain and Eclipse, how to compile and 

debug a simple example using the BlackfinOne board and PEEDI JTAG/BDM Emulator and Flash 

Programmer. 

 

The necessary software components for a Blackfin cross development are: 

 

- GNU toolchain (compiler, linker, gdb) 

- Eclipse IDE including Zylin CDT Plug-in for C/C++ development 

- Java Runtime 

 

To enable a quick start in the Blackfin cross development Ronetix provides pre-built packages for 

Linux and Windows hosts: 

 

- The GNU toolchain: 

http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-elf.2007R1-RC10.070525.tar.bz2 

linked against gcc’s own newlib library. The bfin-elf-* toolchain 

should be used to build non-kernel and non-uClibc applications. 

 

http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-uclinux.2007R1-RC10.070525.tar.bz2 
 

linked against uClibc, which was built by the bfin-elf-* toolchain. 

Use this to build the kernel and kernel modules. Use this to build 

all userspace applications in the FLAT format. 

 

 http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-linux-uclibc.2007R1-
RC10.070525.tar.bz2 

linked against uClibc, which was built by the bfin-elf-* toolchain. 

Use this to build all userspace applications in the FDPIC ELF format. 
 

- The Eclipse IDE  

- A simple http://download.ronetix.info/examples 

 

 

The necessary setup file for a Windows host is (coming soon). 

It is a Windows installer which installs the GNU toolchain, Eclipse IDE + Zylin CDT and Java.
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2 PEEDI Blackfin Emulator 
Installation 

 
PEEDI (Powerful Embedded Ethernet Debug Interface) is a solution that enables you 
to debug software running on Blackfin processor cores via the JTAG port. 
 
In order to debug you need to configure PEEDI JTAG Emulator. The configuration of PEEDI is 
common for both toolchains for Linux and Windows. 
 
You can find detailed information about PEEDI in the PEEDI’s User Manual: 
http://download.ronetix.info/peedi/doc/peedi_rev.A_manual.pdf 
 

- Connect PEEDI to a free port of your LAN switch/hub using the supplied UTP patch cable.   
 

- Connect PEEDI to the target using the supplied JTAG adapter. The JTAG adapter must be on 
the PEEDI side of the JTAG cable: 

 
 

 
 
 
 
 
 

- Connect PEEDI to a COM port of your PC using the RS232 cable. Start any kind of terminal 
emulation program (HyperTerminal) and set it to 115200 bauds, 8 data bits, no parity and no 
flow control. 
 

- Restart PEEDI holding pressed both front panel buttons to enter RedBoot command line. 
 

- Use fconfig command to set the network configuration and other parameters. 
 

WARNING: 
If PEEDI is set to get its network settings from a DHCP server and if the Ethernet cable is 
unplugged or there is no DHCP server on the Ethernet, it may take some time for PEEDI to 
boot. To avoid this, make sure PEEDI can reach a DHCP server or assign a static IP address. 

 
 
- Restart PEEDI again for the changes to take effect 

 
After PEEDI is up and running (this should take some seconds after reset), press and hold the 
green front panel button and PEEDI will start to display its IP address on the display. 
 

Connect to PEEDI with telnet application using the IP address from the previous statement. If 
connected, you should see the PEEDI CLI prompt 

PEEDI 
Target 

Adapter JTAG cable 
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3 Toolset installation on Linux 
 

To install the pre-built from Ronetix GNU cross-development tools: 

Download the GNU tools form here: 

http://download.ronetix.net/toolchain/ronetix-bfin-elf.2007R1-RC10.070525.tar.bz2 

or get it from the CD. 

 
Uncompress the archive: 
Cd / 
tar xvfj ronetix-bfin-elf.2007R1-RC10.070525.tar.bz2 

 
The toolchain will be installed in the /usr/cross/bfin-elf directory. If want to install the toolset in another 

directory make sure you have a symbolic link in the /usr/cross 

 
1. Set a path to the /usr/cross/bfin-elf/bin: in the .bashrc file add the following: 
 
export PATH=$PATH:/usr/cross/bfin-elf/bin 

 
 

2. Test the toolchain installation: 
 

[linbox]$ bfin----elfelfelfelf----gcc gcc gcc gcc ----vvvv 
Using built-in specs. 
Target: bfin-elf 
Configured with: /home/src/cross/blackfin-toolchain-06r2-5/blackfin-
toolchain-06r2/../gcc-4.1/configure --target=bfin-elf --
prefix=/usr/cross/bfin-elf --with-newlib --disable-libstdcxx-pch --
disable-symvers --disable-libssp --enable-version-specific-runtime-libs 
Thread model: single 
gcc version 4.1.1 (ADI 06R2) 

 
 

3. Installing Eclipse IDE 

 

Download the Eclipse IDE from here or get it form the CD: 

http://www.ronetix.at/software.html 

The file eclipse.tar.bz2 includes: 

- Eclipse SDK v3.2.1 

- Embedded CDT v3.1 patched by Zylin 

- Zylin plugin 

- Java Virtual Machine v1.5.0_09 

 

 
cd /usr/local 
tar xvfj eclipse.tar.bz2 

 
Set a path to the /usr/local/eclipse: in the .bashrc file add the following: 
 
export PATH=$PATH:/usr/local/eclipse 

 
4. Installing an example 

 
Download the BF532 example from here: 
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http://download.ronetix.info/examples 

or get it from the CD.   

 
Cd 
mkdir work 
cd work 
tar xvfz blackfinone_example.tar.gz 
 

 
 
At this point you should be able to build, debug and run applications on embedded Blackfin targets. 

You can compile and debug the example manual, from the shell prompt or using Eclipse. The working 

with Eclipse is explained in “Section 5: Working with Eclipse” from this manual. 

 
5. Compiling from the shell 
 
 
[linbox]$ cd echo 
[linbox]$ make 
bfin-elf-gcc -x assembler-with-cpp -c  -g -D__ADSPLPBLACKFIN__   
src/startup.S -o src/startup.o 
bfin-elf-gcc -c  -O0 -g -D__ADSPLPBLACKFIN__   -MD -MP -MF 
.dep/main.o.d -I . -I./. -I./src -I./inc src/main.c -o src/main.o 
bfin-elf-gcc -c  -O0 -g -D__ADSPLPBLACKFIN__   -MD -MP -MF 
.dep/uart.o.d -I . -I./. -I./src -I./inc src/uart.c -o src/uart.o 
bfin-elf-gcc ./src/startup.o ./src/main.o ./src/uart.o  -T"bf532-
ram.ld" -nostdlib -Wl,-Map=echo.map,--cref,--no-warn-mismatch    -o 
echo.elf 
bfin-elf-objcopy -O binary echo.elf echo.bin 

 
 

6. Debugging 
 

From a X-console start the Insight debugger: 

 
 
[linbox] bfin-elf-insight echo.elf 
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The following descriptions discuss the use of the default debugger toolbar buttons. 
 

 
The Run button, do not use this button. Instead of this use the “Continue” button 

 

During the debugging process, the Run button turns into the Stop button to interrupt the 

debugging.  

 

The Continue button continues execution until a breakpoint, watchpoint or exception is 

encountered, or until execution completes. 

 

The Step button steps to next executable line of source code. Also, the Step button steps 

into called functions. 

 

The Next button steps to the next executable line of source code in the current file. Unlike 

the Step button, the Next button steps over called functions. 

 

The Finish button finishes execution of a current frame. If clicked while in a function, it 

finishes the function and returns to the line that called the function. 
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4 Toolset installation on Windows 
 
Please download the GNU toolchain installer from our web site, launch it and follow the instructions. 

http://www.ronetix.at/software.html (comming soon) 

 

The setup will install: 

 

By default, the installer provided by Ronetix installs everything necessary for developing. This 

includes: 

• bfin-elf GNU tools (compiler, linker, and debugger) 

• Eclipse IDE v3.2.1 and Zylin CDT plug-in  

• Java run-time environment for the Eclipse 

• ready-to-build examples  

• a free TFTP server 
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5 Working with Eclipse 
 

5.1 Adding a project 
 

Eclipse (http://www.eclipse.org) is an open-source, Java based, powerful Integrated Development 
Environment (IDE). Adding the CDT plug-in (C/C++ Development Toolkit), you can edit and build C 
programs using the GNU compiler toolkit. A detailed C/C++ Development User Guide for Eclipse can 
be downloaded from http://www.eclipse.org/cdt or from the Ronetix site. 
 
The Java run-time environment, Eclipse and the CDT plug-in are installed by the installer from 
Ronetix. Now start Eclipse IDE using the desktop icon, the “Workspace Launcher” dialog should 
appear, where you need to point the workspace folder. In our case point “C:\Program 
Files\Ronetix\examples\bf532\BlackfinOne”, this way eclipse will automatically include the project files 
when we create a new project. Next click OK. 

 
 

Now click at the "Workbench" icon at the right edge of the window. 
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The next window will look like: 

 
 

Now you need to add as a project the BF532 example. Click File->New->Project. In the New Project 
dialog select Standard Make C Project and click Next: 
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In the “New Project” dialog put “echo” for project name and click Finish. The echo already exists there 
so all of its files will be automatically imported in the new created Eclipse project. 

 

 
 
 

Now Eclipse will ask you to change the perspective to C/C++, check remember my decision and click 
YES: 
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Now the Eclipse window should look like: 
 

 
 

Use the "Project" menu and remove the checkmark at "Build Automatically": 
 

 
 

 
Open echo.c by double clicking on it in the echo/src folder: 
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Now build the project: 
 

 
 

At this point your project should be compiled and liked to a single executable “echo.elf” file. You can 
check its presence. 
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5.2 Configuring and working with the Eclipse built-in debugger 
 

First click the arrow right to the “bug” button and next “Debug…” 
 

 
 
 
 

This opens the Debug configuration dialog. Select Embedded debug (Native) and click the New 
button: 
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This will change the look of the window to: 

 
 
If your window does not look like the previous, follow the next two steps: 
 
1. Enter echo for name and click Project Browse to select the echo and click OK: 
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2 .Next enter echo.elf for C/C++ Application. 

 
 

Now select the Debugger tab and Browse to locate “…\Ronetix\bfin-elf\bin\bfin-elf-gdb.exe”: 
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Now change to the Commands tab and enter these commands considering your PEEDI IP address: 
 

 
 

These command will tell gdb: 
- to connect to your PEEDI 
- to load the project executable file to the target 
 
Next click Apply and Debug, this will start the debugger and Eclipse should ask you: 

 

 
 

Check remember my decision and click YES. 
 

If Eclipse doesn’t automatically switch to the Debug perspective, you can switch manually using menu 
Window -> Open Perspective -> Debug 
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Now the debugger is started: 

 
 

Set a break point where you wish by double clicking the grey margin: 
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Next click the Resume botton. The application is started and shortly it should break were the break 
point is: 

 

 
 
 

At this point you can continue debugging, i.e. step, put breaks, resume, etc. 
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5.3 Using Insight debugger as an Eclipse external tool 
 

I you prefer you can use Insight for a debugger when developing with Eclipse IDE. 
For this reason you need to add it as an external tool by clicking Run->External Tools->External 
Tool… 

 
 
 

In the “External Tools” dialog select Program and click the New button: 
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In the new dialog for name type “Insight”, for location click Browse File System and navigate to 
“…\Ronetix\bfin-elf\bin\bfin-elf-insight.exe”, for Working Directory click Browse Workspace and select 
echo and for Arguments type echo.elf. 

 

 
 



Working with Eclipse 

 

Now click on Common, and in the “Display in favorites menu” select Insight to add it to the Run menu 
and click Apply and Close: 

 

 
 

Now you have Insight in your Run menu. 

 



Working with Eclipse 

 

 
You have just added the Insight. 
 
You can follow the previous procedure to add any external tool you wish to use while developing. 
Now you can start Insight and debug the project. 


