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Appendix A

1 Introduction

This document will show you how easy is to install and use eclipse to debug embedded applications
using PEEDI as a JTAG interface.

We will assume this:
- We already have an existing makefile based project we want to debug, so opening a

console and typing make command should build our project producing and ELF file.

- We have gdb(arm-elf-gdb, powerpc-eabi-gdb or any suitable) installed, usually it is
included in the GNU GCC toolchain used to build the application.

- We have a PEEDI that is configured and successfully connects to the test board.
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2 Installing Eclipse

2.1 Installing Eclipse

First go to the Eclipse website http://www.eclipse.org/downloads/ and download Eclipse IDE for
C/C++ Developers. Extract the contents of the archive somewhere in your PC and start eclipse.
When eclipse opens it will ask you for a workspace directory, choose one or leave the default:

3

3 Workspace Launcher

Select a workspace

Eclipse stores wour projects in a folder called a workspace,
Chonse a warkspace Folder ko use Faor this session,

Workspace: | CiDocuments and Settings! Tikolworkspace|

kl [ Browse, .,

[ ]Use this as the default and do not ask again

Ok ] [ Cancel

Next the eclipse welcome screen is shown:

5 &%) Welcome 22

Welcome to the Eclipse IDE for C/C++ Developers

= CiC++ - Eclipse =G =}
File Edit Source Refactor Mawvigate Search Run Project  Window Help
o 0 ST G R O (S
| = | B+
o e wE e

Workbench

Ga to the warkhench

Click the Go to the workbench button to close it.
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2.2 Installing the Embedded debug plugin

Now go to Help->Install New Software, then click Add and fill the dialog as shown bellow:

= Add Repository

Mame: Zvlin Embedded <OT|

Location: | htkpffopensource . 2ylin, com)zylincdt archive, ..

C’E“jl [ O H Zancel ]

Then check the Zylin Embedded CDT box, click Next and follow the instructions. Eventually you will
be asked to agree restarting eclipse — accept this.
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3 Importing your project

Now click File->New->Makefile Project with Existing Code and the New Project dialog will open,
where you have to navigate to your project, clicking the Browse button. This will fill the project name
automatically — change it or leave, it if you like the suggested name and click Finish:

= Mew Project =%

Import Existing Code

Create a new Makefile project from existing code in that same directory

Projeckt Mame

BasicMMU

Existing Code Location
CDacuments and Settings) Titah Deskkop\BasichmL

Languages

[¥]Z [w]c++

Toalchain For Indexer Settings

<Mone =

Cross GQiCC

GHU Autokools Toalchain
Microsoft Yisual C++

Show only available toolchains that support this platform

(?) Einish l [ Cancel

L

Now your project is imported and if you click the “Hammer” toolbar button it should build successfully.
By default eclipse will execute the make all command to build your project. If it requires another
command, for example make debug, you can set this right clicking on your project and select
Properties and then C/C++ Build. Here you can override the very make command, or in the
Behavior tab, you can change only the make sub-command for example from all to debug:
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= Properties for BasicMiU

]

tvpe filter text| C/C+ + Build
# Resource ]
Builders s
C/C++ Build Configuration: _Defau\t [ active ]

ClC++ General
Project References
FunfDebug Settings
i+ Task Repository

- WikiText Builder

=l Buider settings (@ Behaviour | 7 Pefresh Policy |

Builder bype:
Use default build command

Build cammand:

IMakefile generation

Build location

Build directory: | ${workspace_loc: [BasichmL}:

&)

-

| |Manage Configuration:

Workspace. .. ] [F\Ie systen, ., ] lVariabIes.‘. ]

[Restore Qefaults] [ Apply ]

= Properties for BasicMiU

C/C+ + Build
Resource ]
Builders s
C/C++ Build Configuration: | Default [ Active ]

ClC++ General
Project References
FunfDebug Settings

| Behaviolr | % Pefresh Policy |

| |=} Builder Settings

Task Repository
- WikiTest Build settings

[¥] stop on first build errar
‘Workbench Build Behavior
wiorkbench build type: Make build target:
[C1Build on resouree save (auta build)
Note! See Warkbench automatic build preference

Build {Incremental build) al
Clean clean
@

: % | | Manage Configurations...

[1Enable parallel build

[Restore Qefaults] [ Apply ]
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Finally the C/C++ perspective should look like this:

"= C/C++ - BasicMMU/src/main.c - Eclipse
File Edit Source Refactor Mavigate Search Project Run Window Help
o S S S R A CRAE S B TS G = I _
[ Project Explorer 23 | [€ main.c &2 = m For ™ =8
= 7 —int mali.n{void] Rl - lﬂz = 3,‘3 e %
{ -
roid (*pDhrystone) (void) = (void (%) (void)) ([ (unsigned -
ATS1F_DEGU Frintk("-I- Enter in main() sectioninir"); <l stdinh
- = ATI15AMIZEL R
P [§ cetartup.s ATS1F_DEGU Printk("-I- no MMU, I+D Caches Dissbledinir <= lib_ATSISAMIZELh
; — o =
B s e AT91F Disabls=ICache(); <& mruh
dhry 2.6 ATS1F_DisableDCache() ; & TR ENTRIES Wi
& dhry_h AT91F Dhrystone(]; 5 ' tth_array @ unsigned ir
] ~++  AT91F_DBGL_Printkicl
nic, c 5 . J
R — ATS1F_DEGU_Printk(™nir-I- no MMU, I Cache Ensbledinir st tastoopfirit): weid
i = ATS91F EnsbleICache () ; ~ @  AT91F_Dhrystone(voic
B it LT91F Dhrystome() ; @ ATI1F_InitMMU{unsigr
- @ mainiyoid) ;int
[Bl mmuh y
& BasicMMULelf LTO1IF_InitMMU(tth_array):
|z makefile (||
ATQlF_DBGU_Prlnt,k("\ nhr—I- MMT & I Cache Enabled) n\r");
AT91F _EnablelCache(): |
phhrystone |} ; // wall the function from the
]
s i I 3 g 3
Prablems Tasks B Console 22 Proper i i ol e |
Noconsoles ko display at this time,
fm | 3
Writable Smatt Insett: 128:7
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4 Setting the debug configuration

Now click on your project on the left pane just to select it and then click the down arrow on the right of
the “Bug” toolbar button and select Debug configurations, this opens the following dialog:

= Debug Configurations

Create, manage, and run configurations

L+ —*l

o Canfigure launch settings from this dialog:
[ - Press the 'Mew' button ko create a configuration of the selected type.
E CIC++ Application =| - Press the 'Duplicate’ button ko copy the selected configuration.

[E] C/C++ fktach ko Application

E CJC++ Postmortemn Debugger

[C] C}C++ Remate Application :{=:b - Press the 'Filket' butkon ta confiqure Filkering options.
Java Applet
Java Application

@ Launch Group
Remote Java Application Configure launch perspective settings from the 'Perspectives' preference page.

3G Zylin Embedded debug {Cwgwin)

2 iZylin Embedded debug (Mative)

3 - Press the 'Delete’ button ta remove the selected configuration.

- Edit or view an existing configuration by selecting it,

Filter matched 10 of 10 items

3

Double clicking on the Zylin Embedded debug (Native) will create a new debug configuration, named
on your project, here you will need to enter or select the project ELF file:
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= Debug Configurations

Create, manage, and run configurations

o —*l
T ERX B F- Mame: | BasicMMU Default

=] Main f’;. Cebugger | Fll Commands 'Egy Source E Ervironment | £ Cammon
E CJC++ Application
€] cjc++ Attach to Application

[C] cfC++ Postmortem Debugger BasiELILC

Project {optional):

E ZJC++ Remote Application C/C++ Application:
Java Applet EasichrMU. elf| Search Project... ] [ Browse, ., ]
Jawa Application

v

Launch Group [l application consale
Remaote 1ava Application

Zylin Embedded debug {Cygwin)
Zvlin Embedded debug {Mative)
Z; BasicMMU Default

|
LTI
o o

Filker matched 11 of 11 items [ Apply ] [ Rewvert ]
|§:' [ Debug ] [ Clase ]

Next open the debugger tab and make sure the right gdb is selected as GDB debugger, for ARM
targets it should be arm-xxx-gdb, for example arm-elf-gdb, arm-none-gnueabi-gdb or just the gdb that
comes with your GCC toolchain. If the selected debugger is not found because its path is not set
correctly, you can use the Browse button to exactly point to it and thus exclude any path problems.
Next open the Commands tab and fill it like this considering your PEEDI IP:
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= Debug Configurations

Create, manage, and run configurations

o —+|
TE X | B3 Mame: | BasichMU Default

=] Main ﬁ& Debugger | Bl Commands EV Source E Ervironment | =] Cormman

E CIC++ Application
[E] C/C++ fktach ko Application
E CJC++ Postmortemn Debugger
E CJC++ Remate Application :::arget remote 192, 168,10,22:2000

Jawa Applet 5i

Java Application
@ Launch Group
Remote Java application
Zylin Embedded debug {Cwgwin)
¢ Zvlin Embedded debug {Mative) 'Run’ commands

(G BasicMMU Default

Helpjtips on hiow bo setup GDE init scripk

'Initialize' commands

iy
o

Filter matched 11 of 11 items [ Apply ][ Reyert ]

'@J I Debug l [ Close ]

The target remote command tells to gdb to connect to PEEDI using the provided IP address. The
load command loads the code to be debugged to the target (in this case it loads it to the RAM). The si
command tells the gdb to make a single step just to refresh the eclipse debug view. After finished click

Debug, this will start a debug session and eclipse will ask you to witch to debug perspective, click
Remember my decision and then Yes:

= Confirm Perspective Switch

D] This kind of launch is configured to open the Debug perspective when it
\:I/J suspends,

This Debug perspective is designed to support application debugging, It
incaorparates views for displaying the debug stack, wariables and breakpoint
management.,

Do ol wank to open this perspeckive now?

[«]Remember my decision:

This will open the debug perspective.
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5 Debugging

Here is the debug perspective opened.

= Debug - BasichMU/src/cstartup. S - Eclipse BE =]
File Edit MNavigate Search Project Run window Help
L il et » AL el S B e s £ e S e
£ | DEc/cr+ | ¥ Debug |
ﬁ&DEhug 0 NiEe Y= 0 69= Variables &7 Breakpoints 371 Registers. =), Modules SE
1= 3G BasicMMU Default [Zylin Embedded debug (Native)] ¥ oaf = fd“ e =
é{;} Embedded GDE (11,0310 17:03) (Suspended)
. Euf® Thread [0] (Suspended)
i = 11 ResetHandlert) cstarbup.5:98 020000044 |
B CiiDocuments snd Settings) Tikol Deskbop)insightibin arm-sabi-gdb, exe (11.03.10 17:03
(€l m ey
[8] cstartup.5 22 S | Coutine 52 @ BE Y= B
® 1ldre 0, [rl, #PMCJ\ICKR] i < B yeckars .A.;
movw rz, #0x3 ~ & ResetAddr
and r3, rl, rz = Undefaddr
cmp r4, #0 = SWIaddr
hne skip_pll_init = Pabortaddr
= DaborkAddr
« B Reservediddr
//PC100 SDRLM <& IRGAddr
ldr r0, =0x00603F0% /#- FCK = 198, 6MHz, quartz 16.432MHz ©  FIoAddr
A ldr r0, =0x004=83F0e //— PCE = 98, 6MHz, guartz 18.43ZMHz =  ResetHandler
-8 _main
//PC133 SDRAM ol @ _main i
#H-= end [l
=l Console &2 Tasks Problerns Exzcutables Mernary L] w | L & =200
BasicMMU Defaule [Zylin Embedded debug (Native)] Ct\Documents and Settings\TitoiDesktoplinsightibiniarm-eabi-gdb.exe (11.08.10 17:03)
0x10000040 in 27 () »|
load
Loading sectioh .text, size Oxac30 lma 0x20000000
Loading section .data, size 0Ox546 lwa 0x2Z000zc30
Start address 0x20000040, losd size 46200 v

Now you can continue debugging normally, i.e. do some single steps, put breaks or hit the resume
button to start the executions. You can insert a break clocking on the beginning of the desired line in
the source file, for example | will click on the C/C++ perspective just to see the source files, so | can
open init.c, then | will switch back to the debug perspective and put a break on the first line of
AT91F_LowLevellnit() function:
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= Debug - BasicMMUfsrcfinit.c - Eclipse =&
File Edit Source Refactor Mavigate Search Project Run Window Help
3 ST nal ALt NS w SIS R R s e, B =2 S A I R e e
| B | ERcice+ |35 Debug |
¥ Debug 22 Blid Y5 B e=Varables 52 = iE
= FG BasicMMU Default [Zylin Embedded debug (Mative)] E¥ ==
= &% Embedded GDE (11,03,10 17:26) (Suspended) —
i=-® Thread [0] (Suspended)
H = | ResetHandler() cstarbup,5:98 020000044
gl CiDacuments and Settings)Tito\Deskkoplinsightibintarm-eabi-gdb.exe (11.03.10 17
=28 I |
[8] cstartup.5 [g] init.c 52 = m 8= Outline £2 =g
void AT91F LowLevelInit (void) | P EEE e ¥ ~
i - @ AT9IF_SpuriousHandler(void) | | |
o LT91PS MATRIX  pHwatrix = AT91C_EASE MATRIX; - @ ATAIF Datatbart(veid) : void
@ AT91F_Fetchabort(void) : void
// enshle user reset ®  ATOIF_Undef(void)  void
*[ATS1C_R3ITC RMR) = 0OxAS000001; -~ ®  AT9IF_UndefHandler(vaid) © vof
- @ ATYIF_InitSDRAM{void) ; void | =
// Disable watchdog @  ATOIF_Lowlevellnit(void) : voic
*{ATS1C_WDTC_WDMR) = ATS1C WDTC WDDIS: |we |
[¢ | < >
El Console 2 Tasks Problems Executables Mernary = B [E e = B
BasicMMU Defaulk [Zylin Embedded debug (Mative)] CiiDocuments and Settings) Ticol Deskboplinsightbind arm-eabi-gdb.exe (11.03.10 17:26)
R o e T e e s ey pe g e and et [ReiDestopinsgitpnaricesigeb.exe AL 10 11220 —
ag ldr r0, [r1, #PMC_MCKR] I
Current language: auto; currently asm
w2
Writable Smatt Insett: 158 : 24

Hitting the Resume toolbar button or F8 will start the target and a moment later hit the break | set:

= Debug - BasicMMUfsrcfinit.c - Eclipse =&
File Edit Source Refactor Mavigate Search Project Run Window Help
55 ST ey AU A S SN R R e e R =S i S TSR i s e
| B | ERcice+ |35 Debug |
¥ Debug 22 i Y =8 ®)=Variables 52 ®g Breakpoints 11 Registers Mocules =

G BasicMMU Defaulk [Zylin Embedded debug (Mative)] fo" E¥ ==
&2 Embedded GDE (11.03,10 17:26) {Suspended) — b
=0 Thread [0](3 ded: B int hit.,
. _rea [I{5uspende .re‘?k.poln I # s pHmatriz Qxffffesnn
= 2 AT91F_LowlevelInit() init.c: 160 0x20000%cc
= 1 skip_pll_init(} cstartup.5:154 02000000
gl CHDocuments and Settings)Tito\Deskkoplinsightibintarm-gabi-gdb, exe (11,03.10 17
=28 I |
[8] cstartup.5 [ init.c 53 = m 8= Outline £2 =g
void AT91F LowLevellInit (void) i = 5 132 ‘w{ \&3 @ * s
i - @ AT9IF_SpuriousHandler(void) | | |
%o |  AT91PS MATRIX  pHwatrix = ATS1C BASE MATRIX: @ ATOIF Datadbert{void) : void
@ AT91F_Fetchabort(void) : void
/f ensble user reset ©  ATOIF_Undef{vaid) | void
*[ATS1C_R3ITC RMR) = 0OxAS000001; + @  AT9IF UndefHandler(void) : vol |
-~ @ ATIF_InitSDRAM(vaid)  void | =
/4 Disable watchdog @  ATOIF Lowlevellnit(void) : voic |
*{ATS1C_WDTC_WDMR) = ATS1C WDTC WDDIS: |»e V.
£ | > £3 1l | *|
El Console 2 Tasks Froblems Executables Mernary B X 4 = & | LB E e = B
BasicMMU Default [2ylin Embedded debug (Hative)] CiDocuments and settingsiTitaiDesktopiinsightibiniarm-eabi-gdb.exe (11.03.10 17:26) :
Current language: &auto} currently @sm ]
Current lancguage: auto; currently o

Writable Smatt Insett: 1601

If you want to restart the debug just right click on the debug session BasicMMU Defgault and select
Relaunch or whatever action you need to take. To again start the debug session from the C/C++

perspective just clock the down arrow on the right of “Bug” toolbar button and select your project
debug configuration.
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6 Conclusion

As you can see Eclipse is a rich feature IDE and more and more companies use it as a development
environment. It has all of the known IDE functionalities and much more, installing the right plugin from
Help->Marketplace. For example the subclipse plugin allows you to synchronize your project with a
SVN repository using the Team Synchronization perspective, which is much easier then using the
command line svn client.
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